Web Requests Degraded

Resolved

This issue has been resolved.
Posted Aug 07, 2026 - 06:58 UTC

Investigating

We are currently investigating an issue that can cause websites to time out.
Posted Aug 07, 2026 - 05:54 UTC
This incident affected: Web Requests (HTTP / HTTPS) (North America).