GoDaddy Logo

Managed WordPress 2.0 Status Page

Partial Outage in Site Creation

Incident Report for Managed WordPress V2 Status

Resolved

The issue has been fully addressed, and all systems have returned to normal operation. We have confirmed that the problem is resolved.
Posted Apr 01, 2025 - 16:21 UTC

Investigating

We are currently experiencing a partial outage affecting Site Creation. Our technical team is investigating the issue to identify the cause and implement a solution. Expect a status update within 1 hour.
Posted Apr 01, 2025 - 15:51 UTC
This incident affected: Site Creation (North America).