GoDaddy Logo

Managed Hosting for WordPress 2.0 Status Page

Performance Degradation in Web/FTP

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 01:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 01:17 UTC

Update

We are continuing to investigate this issue.
Posted Apr 01, 2026 - 23:58 UTC

Investigating

We are currently experiencing a partial outage affecting Web/FTP. Our technical team is investigating the issue to identify the cause and implement a solution. Expect a status update within 1 hour.
Posted Apr 01, 2026 - 23:57 UTC
This incident affected: Web Requests (HTTP / HTTPS) (North America) and File Uploads / Command Line (SSH / SFTP) (North America).