Managed WordPress Hosting Sites Degraded

Resolved

This issue has been resolved.
Posted Aug 21, 2026 - 10:10 UTC

Investigating

We are currently investigating an issue causing websites hosted on the Managed WordPress Hosting platform to be unavailable in US region.
Posted Aug 21, 2026 - 07:19 UTC
This incident affected: Web Requests (HTTP / HTTPS) (North America).