GoDaddy Logo

Managed Hosting for WordPress 2.0 Status Page

App Creation Issues

Resolved

This incident has been resolved.
Posted May 18, 2026 - 17:55 UTC

Monitoring

GoDaddy has identified and corrected the root cause of this issue, and is monitoring.
Posted May 18, 2026 - 17:39 UTC

Update

We also are seeing issues with some outbound network requests from hosted sites, and are continuing to investigate.
Posted May 18, 2026 - 17:31 UTC

Investigating

We are investigating an issue that may delay or prevent creation of new apps. We will post more details as they become available.
Posted May 18, 2026 - 17:09 UTC
This incident affected: Web Requests (HTTP / HTTPS) (North America, Europe) and Site Creation (North America, Europe).