GoDaddy Logo

Managed Hosting for WordPress 2.0 Status Page

Staging App Creation Issues

Resolved

This incident has been resolved.
Posted May 01, 2026 - 12:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 11:25 UTC

Investigating

Our team is investigating issues impacting staging app creation
Posted May 01, 2026 - 05:40 UTC
This incident affected: Site Creation (North America, Europe) and SSL Certificates (North America, Europe).